Error updating from 1.8 to 1.9

classic Classic list List threaded Threaded
12 messages Options
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Error updating from 1.8 to 1.9

Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)

[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

pesetebin link  http://pastebin.com/a2i1QnAe


On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list
Daniel Kayiwa Daniel Kayiwa
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

In reply to this post by Matthew Ssemakadde

Hi Mathew,

Are you trying out 1.9 RC2?
Can you also put the contents of the entire tomcat log at pastebin.com and send us the url?


On Tue, Apr 10, 2012 at 1:02 PM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)

[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list
Daniel Kayiwa Daniel Kayiwa
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

In reply to this post by Matthew Ssemakadde

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

In reply to this post by Daniel Kayiwa
http://pastebin.com/a2i1QnAe

On Tue, Apr 10, 2012 at 3:46 AM, Daniel Kayiwa <[hidden email]> wrote:

Hi Mathew,

Are you trying out 1.9 RC2?
Can you also put the contents of the entire tomcat log at pastebin.com and send us the url?


On Tue, Apr 10, 2012 at 1:02 PM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)

[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

am trying 1.9RC2

On Tue, Apr 10, 2012 at 4:37 AM, Matthew Ssemakadde <[hidden email]> wrote:
http://pastebin.com/a2i1QnAe


On Tue, Apr 10, 2012 at 3:46 AM, Daniel Kayiwa <[hidden email]> wrote:

Hi Mathew,

Are you trying out 1.9 RC2?
Can you also put the contents of the entire tomcat log at pastebin.com and send us the url?


On Tue, Apr 10, 2012 at 1:02 PM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)

[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list



[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

In reply to this post by Daniel Kayiwa
Daniel,
Am trying 1.9RC2

On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Ben Wolfe (openmrs) Ben Wolfe (openmrs)
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

Very interesting Mathew.  Thanks for the pastebin.  Can you do a "describe notification_alert" in your mysql command line?  And "show create table notification_alert" 

I think this is a bug in liquibase in how it is looking up and reporting indexes.  The 201011051300 changeset deals with the notification_alert table, not the patient_flags table.  (patient_flags is never referred to from core as its a module)

Ben

On Wed, Apr 11, 2012 at 1:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Daniel,
Am trying 1.9RC2


On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

am now trying to update from 1.8 to 1.9.0RC3
and am getting the following  error

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.visit_attribute_type' doesn't exist ???
  • ???:???

the paste bin links is http://pastebin.com/8MFc5Y3k


Matthew
Masaka(Ug)


On Thu, Apr 12, 2012 at 5:35 AM, Ben Wolfe <[hidden email]> wrote:
Very interesting Mathew.  Thanks for the pastebin.  Can you do a "describe notification_alert" in your mysql command line?  And "show create table notification_alert" 

I think this is a bug in liquibase in how it is looking up and reporting indexes.  The 201011051300 changeset deals with the notification_alert table, not the patient_flags table.  (patient_flags is never referred to from core as its a module)

Ben


On Wed, Apr 11, 2012 at 1:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Daniel,
Am trying 1.9RC2


On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Daniel Kayiwa Daniel Kayiwa
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9


Mathew,

Which version of MySQL are you running?
Do you have any anti virus software running? If yes, does the upgrade work after you temporarily turn it off?


On Fri, Apr 13, 2012 at 2:39 PM, Matthew Ssemakadde <[hidden email]> wrote:
am now trying to update from 1.8 to 1.9.0RC3
and am getting the following  error

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.visit_attribute_type' doesn't exist ???
  • ???:???

the paste bin links is http://pastebin.com/8MFc5Y3k


Matthew
Masaka(Ug)



On Thu, Apr 12, 2012 at 5:35 AM, Ben Wolfe <[hidden email]> wrote:
Very interesting Mathew.  Thanks for the pastebin.  Can you do a "describe notification_alert" in your mysql command line?  And "show create table notification_alert" 

I think this is a bug in liquibase in how it is looking up and reporting indexes.  The 201011051300 changeset deals with the notification_alert table, not the patient_flags table.  (patient_flags is never referred to from core as its a module)

Ben


On Wed, Apr 11, 2012 at 1:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Daniel,
Am trying 1.9RC2


On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list
Ben Wolfe (openmrs) Ben Wolfe (openmrs)
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

In reply to this post by Matthew Ssemakadde
That 201011051300 is still the same one from before, just a different error message from liquibase (a bug on their part)

Can you do a "describe notification_alert" in your mysql command line?  And also "show create table notification_alert"
Paste the output here.



On Fri, Apr 13, 2012 at 7:39 AM, Matthew Ssemakadde <[hidden email]> wrote:
am now trying to update from 1.8 to 1.9.0RC3
and am getting the following  error

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.visit_attribute_type' doesn't exist ???
  • ???:???

the paste bin links is http://pastebin.com/8MFc5Y3k


Matthew
Masaka(Ug)



On Thu, Apr 12, 2012 at 5:35 AM, Ben Wolfe <[hidden email]> wrote:
Very interesting Mathew.  Thanks for the pastebin.  Can you do a "describe notification_alert" in your mysql command line?  And "show create table notification_alert" 

I think this is a bug in liquibase in how it is looking up and reporting indexes.  The 201011051300 changeset deals with the notification_alert table, not the patient_flags table.  (patient_flags is never referred to from core as its a module)

Ben


On Wed, Apr 11, 2012 at 1:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Daniel,
Am trying 1.9RC2


On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Matthew Ssemakadde Matthew Ssemakadde
Reply | Threaded
Open this post in threaded view
|

Re: Error updating from 1.8 to 1.9

ben
describe notification_alert
alert_id    int(11)    NO    PRI        auto_increment
text    varchar(512)    NO           
satisfied_by_any    int(1)    NO        0   
alert_read    int(1)    NO        0   
date_to_expire    datetime    YES           
creator    int(11)    NO    MUL       
date_created    datetime    NO        0000-00-00 00:00:00   
changed_by    int(11)    YES    MUL       
date_changed    datetime    YES           
uuid    char(38)    NO    UNI       


show create table notification_alert
DROP TABLE IF EXISTS `notification_alert`;
CREATE TABLE `notification_alert` (
  `alert_id` int(11) NOT NULL auto_increment,
  `text` varchar(512) NOT NULL,
  `satisfied_by_any` int(1) NOT NULL default '0',
  `alert_read` int(1) NOT NULL default '0',
  `date_to_expire` datetime default NULL,
  `creator` int(11) NOT NULL,
  `date_created` datetime NOT NULL default '0000-00-00 00:00:00',
  `changed_by` int(11) default NULL,
  `date_changed` datetime default NULL,
  `uuid` char(38) NOT NULL,
  PRIMARY KEY  (`alert_id`),
  UNIQUE KEY `notification_alert_uuid_index` (`uuid`),
  KEY `alert_creator` (`creator`),
  KEY `user_who_changed_alert` (`changed_by`),
  CONSTRAINT `alert_creator` FOREIGN KEY (`creator`) REFERENCES `users` (`user_id`),
  CONSTRAINT `user_who_changed_alert` FOREIGN KEY (`changed_by`) REFERENCES `users` (`user_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;


On Fri, Apr 13, 2012 at 4:20 AM, Ben Wolfe <[hidden email]> wrote:
That 201011051300 is still the same one from before, just a different error message from liquibase (a bug on their part)

Can you do a "describe notification_alert" in your mysql command line?  And also "show create table notification_alert"
Paste the output here.




On Fri, Apr 13, 2012 at 7:39 AM, Matthew Ssemakadde <[hidden email]> wrote:
am now trying to update from 1.8 to 1.9.0RC3
and am getting the following  error

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.visit_attribute_type' doesn't exist ???
  • ???:???

the paste bin links is http://pastebin.com/8MFc5Y3k


Matthew
Masaka(Ug)



On Thu, Apr 12, 2012 at 5:35 AM, Ben Wolfe <[hidden email]> wrote:
Very interesting Mathew.  Thanks for the pastebin.  Can you do a "describe notification_alert" in your mysql command line?  And "show create table notification_alert" 

I think this is a bug in liquibase in how it is looking up and reporting indexes.  The 201011051300 changeset deals with the notification_alert table, not the patient_flags table.  (patient_flags is never referred to from core as its a module)

Ben


On Wed, Apr 11, 2012 at 1:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Daniel,
Am trying 1.9RC2


On Tue, Apr 10, 2012 at 4:25 AM, Daniel Kayiwa <[hidden email]> wrote:

Mathew,

Are you trying out 1.9 RC2?
Am still wondering since we do not reference the "patientflags_flag" table anywhere in that liquibase file.


On Tue, Apr 10, 2012 at 2:32 PM, Matthew Ssemakadde <[hidden email]> wrote:
pesetebin link  http://pastebin.com/a2i1QnAe



On Tue, Apr 10, 2012 at 2:02 AM, Matthew Ssemakadde <[hidden email]> wrote:
Hi All

am getting the flowing error while updating?

  • ??? Reason: ???
  • ??? Caused By: Precondition Error???
  • ???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201011051300::bwolfe:???
  • ??? liquibase-update-to-latest.xml : Table 'openmrs.patientflags_flag' doesn't exist ???
  • Unable to update the database. See server error logs for the full stacktrace.
  • ???:???

any help??


Matthew
Masaka(Ug)


[hidden email] from OpenMRS Implementers' mailing list



--
If we keep uppermost in our minds the unkind and unjust acts of others, we shall find it impossible to love them as Christ has loved us; but if our thoughts dwell upon the wondrous love and pity of Christ for us, the same spirit will flow out to others.

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list