Important announcement regarding metadatasharing and sync

classic Classic list List threaded Threaded
2 messages Options
Michael Seaton Michael Seaton
Reply | Threaded
Open this post in threaded view
|

Important announcement regarding metadatasharing and sync

Hi all,

Today we discovered a suspected serious incompatibility between the 1.x line of the metadatasharing module and the sync module.  This is currently being investigated.  We recommend that until further notice that these modules not be installed concurrently.  For anyone currently running both of these modules, we ask that you please check your systems and assess whether or not sync is operating as expected for you.  If you find a problem, please reply to this thread and let us know.  We will do our best to assist you.  If you are not having problems, this would be useful for us to know as well, and would appreciate you letting us know what version of OpenMRS and modules you are currently running, so we can further isolate this problem.

@Erick Mugoma and @Jim Grace - I suspect that this is the same problem that you raised in this thread recently, can you confirm?
http://openmrs-mailing-list-archives.1560443.n2.nabble.com/Re-SYNC-Module-Question-tt7430940.html


Thanks,
Mike

[hidden email] from OpenMRS Implementers' mailing list
Rafal Korytkowski-2 Rafal Korytkowski-2
Reply | Threaded
Open this post in threaded view
|

Re: Important announcement regarding metadatasharing and sync

Hi,

Further investigation lead us to a discovery that the metadatasharing module (versions 1.0.3, 1.0.4, 1.0.5) broke not only the sync module, but also disabled auditing in OpenMRS (date_changed, changed_by, etc., did not get updated). It is very important to update to version 1.0.6 which fixes the problem.

We learned that the problem was caused by BeanFactoryPostProcessor which should never be used in OpenMRS since it breaks our interceptors. The alternative is BeanPostProcessor. Please have that in mind developing your modules. See https://tickets.openmrs.org/browse/META-218 for details.

-Rafał

On 13 April 2012 23:25, Michael Seaton <[hidden email]> wrote:
Hi all,

Today we discovered a suspected serious incompatibility between the 1.x line of the metadatasharing module and the sync module.  This is currently being investigated.  We recommend that until further notice that these modules not be installed concurrently.  For anyone currently running both of these modules, we ask that you please check your systems and assess whether or not sync is operating as expected for you.  If you find a problem, please reply to this thread and let us know.  We will do our best to assist you.  If you are not having problems, this would be useful for us to know as well, and would appreciate you letting us know what version of OpenMRS and modules you are currently running, so we can further isolate this problem.

@Erick Mugoma and @Jim Grace - I suspect that this is the same problem that you raised in this thread recently, can you confirm?
http://openmrs-mailing-list-archives.1560443.n2.nabble.com/Re-SYNC-Module-Question-tt7430940.html


Thanks,
Mike

[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list