Re : [OPENMRS-IMPLEMENTERS] Re : [OPENMRS-IMPLEMENTERS] List of forms not showing up

classic Classic list List threaded Threaded
2 messages Options
gilbert uwayezu gilbert uwayezu
Reply | Threaded
Open this post in threaded view
|

Re : [OPENMRS-IMPLEMENTERS] Re : [OPENMRS-IMPLEMENTERS] List of forms not showing up

Yeah ,I realized  that the Openmrs version is still  1.3.X as I still have the one of 30 July  the schema is  1.4.0.01 , I will keep using  Safari as it is giving me the list of forms while waiting for the new Openmrs Version.
Thanks.



De : Maros Cunderlik <[hidden email]>
À : [hidden email]
Envoyé le : Samedi, 15 Novembre 2008, 14h38mn 05s
Objet : Re: [OPENMRS-IMPLEMENTERS] Re : [OPENMRS-IMPLEMENTERS] List of forms not showing up

Gilbert,

There really isn't 1.4.0.01 release (there is an update to schema that has that number but we didn't release that version of software for use in production systems yet).

For the latest released software you should always look at the release branches (1.3.x, etc.). At this moment, the latest released code is 1.3.2.  We are in processing of testing 1.4.x; thus you will see 1.4.x release branch in svn, however you may also notice that we haven't tagged it yet -- meaning we are regression testing it right now and  it hasn't yet been 'qualified' 'release-worthy'. There is a nice write-up on how this is supposed to work: http://openmrs.org/wiki/Release_Process  Of course you can always just use binaries from the download area. Finally just to state the perhaps obvious: do not run trunk in production unless you understand in detail pros/cons of  such approach.

Depending on your situation, you can 
a) revert back to 1.3.2 if you are just experimenting at this point
b) if you are in 'production' use (i.e. there is an expectation of being able to keep the data already entered), you should wait until we have 1.4.x stabilized and you should update to that. 

If you did deploy 1.4.01 off trunk and you don't want to wait, you can update to head of 1.4.x release branch and update with it as we are stabilizing it for release to production -- unfortunately, in this case you are using development version of code; meaning bugs are still being found and fixed.

Hope this helps!

Maros


On Sat, Nov 15, 2008 at 5:15 AM, gilbert uwayezu <[hidden email]> wrote:
Thanks Maros, Yes  I am using Firefox 3 and the version is  1.4.0.01, I tried with Apple safari and it worked , may be I need to wait for the Version: 1.4.0.01 release..., is there any one using Version: 1.4.0.01  and had the same issue ?
Thanks ,

Gilbert.



De : Maros Cunderlik <[hidden email]>
À : [hidden email]
Envoyé le : Samedi, 15 Novembre 2008, 12h15mn 17s
Objet : Re: [OPENMRS-IMPLEMENTERS] List of forms not showing up

Are you using Firefox 3? If so, make sure you update to the latest code or release branch. There were some dojo issues that, I believe, Ben identified and fixed.  I think the fix was back ported to 1.3.x release branch also. 

Hope this helps!

Maros

On Sat, Nov 15, 2008 at 3:59 AM, gilbert uwayezu <[hidden email]> wrote:
I am entering data in infopath and submitting successfully but when I refresh the page to see the encounter the form list disappears , and sometimes when I click on find patient when he shows up the form tab comes without the list of forms so that i can enter data and some other times it works properly .
any idea to keep it work in normal ways ?
Gilbert..



[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list
Maros Cunderlik Maros Cunderlik
Reply | Threaded
Open this post in threaded view
|

Re: Re : [OPENMRS-IMPLEMENTERS] Re : [OPENMRS-IMPLEMENTERS] List of forms not showing up

Gilbert, of course this is your call, but I really think at some point soon you should switch to 1.4.x branch if you plan on production-like use.

Maros

On Mon, Nov 17, 2008 at 1:04 AM, gilbert uwayezu <[hidden email]> wrote:
Yeah ,I realized  that the Openmrs version is still  1.3.X as I still have the one of 30 July  the schema is  1.4.0.01 , I will keep using  Safari as it is giving me the list of forms while waiting for the new Openmrs Version.
Thanks.



De : Maros Cunderlik <[hidden email]>
À : [hidden email]
Envoyé le : Samedi, 15 Novembre 2008, 14h38mn 05s
Objet : Re: [OPENMRS-IMPLEMENTERS] Re : [OPENMRS-IMPLEMENTERS] List of forms not showing up

Gilbert,

There really isn't 1.4.0.01 release (there is an update to schema that has that number but we didn't release that version of software for use in production systems yet).

For the latest released software you should always look at the release branches (1.3.x, etc.). At this moment, the latest released code is 1.3.2.  We are in processing of testing 1.4.x; thus you will see 1.4.x release branch in svn, however you may also notice that we haven't tagged it yet -- meaning we are regression testing it right now and  it hasn't yet been 'qualified' 'release-worthy'. There is a nice write-up on how this is supposed to work: http://openmrs.org/wiki/Release_Process  Of course you can always just use binaries from the download area. Finally just to state the perhaps obvious: do not run trunk in production unless you understand in detail pros/cons of  such approach.

Depending on your situation, you can 
a) revert back to 1.3.2 if you are just experimenting at this point
b) if you are in 'production' use (i.e. there is an expectation of being able to keep the data already entered), you should wait until we have 1.4.x stabilized and you should update to that. 

If you did deploy 1.4.01 off trunk and you don't want to wait, you can update to head of 1.4.x release branch and update with it as we are stabilizing it for release to production -- unfortunately, in this case you are using development version of code; meaning bugs are still being found and fixed.

Hope this helps!

Maros


On Sat, Nov 15, 2008 at 5:15 AM, gilbert uwayezu <[hidden email]> wrote:
Thanks Maros, Yes  I am using Firefox 3 and the version is  1.4.0.01, I tried with Apple safari and it worked , may be I need to wait for the Version: 1.4.0.01 release..., is there any one using Version: 1.4.0.01  and had the same issue ?
Thanks ,

Gilbert.



De : Maros Cunderlik <[hidden email]>
À : [hidden email]
Envoyé le : Samedi, 15 Novembre 2008, 12h15mn 17s
Objet : Re: [OPENMRS-IMPLEMENTERS] List of forms not showing up

Are you using Firefox 3? If so, make sure you update to the latest code or release branch. There were some dojo issues that, I believe, Ben identified and fixed.  I think the fix was back ported to 1.3.x release branch also. 

Hope this helps!

Maros

On Sat, Nov 15, 2008 at 3:59 AM, gilbert uwayezu <[hidden email]> wrote:
I am entering data in infopath and submitting successfully but when I refresh the page to see the encounter the form list disappears , and sometimes when I click on find patient when he shows up the form tab comes without the list of forms so that i can enter data and some other times it works properly .
any idea to keep it work in normal ways ?
Gilbert..



[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list


[hidden email] from OpenMRS Implementers' mailing list