svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

classic Classic list List threaded Threaded
8 messages Options
Mathias Lin Mathias Lin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

I try to build ('mvn install') the webservices.rest module project,
and getting an error as below:

[ERROR] Failed to execute goal
org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
project webservices.rest-omod: Cannot get the revision information
from the scm repository :
[ERROR] Exception while executing SCM command. svn: The path
'/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
appears to be part of a Subversion 1.7 or greater
[ERROR] working copy.  Please upgrade your Subversion client to use this
[ERROR] working copy.


However, my svn command-line client is version 1.7.4. (I only use the
command line, not any other IDE-integrated tools, not Subclipse, etc.)
(I'm on Mac OS X Lion.) Is the svn command-line client that I'm
calling not the same that MVN SCM would be using?
The error only occurs in the OMOD section, not the API or the main.

This is the error/log:

[INFO] Reactor Summary:healthcare
[INFO]
[INFO] Rest Web Services ................................. SUCCESS [0.293s]
[INFO] Rest Web Services API ............................. SUCCESS [4.558s]
[INFO] Rest Web Services OMOD ............................ FAILURE [2.022s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 7.725s
[INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
[INFO] Final Memory: 11M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
project webservices.rest-omod: Cannot get the revision information
from the scm repository :
[ERROR] Exception while executing SCM command. svn: The path
'/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
appears to be part of a Subversion 1.7 or greater
[ERROR] working copy.  Please upgrade your Subversion client to use this
[ERROR] working copy.
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with
the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :webservices.rest-omod


Checking svn client version:

MacBookPro:webservices.rest myuser$ svn help
usage: svn <subcommand> [options] [args]
Subversion command-line client, version 1.7.4.

I've searched for this issue on StackOverflow before and found two
related threads, but not a answer for my case.

http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
http://stackoverflow.com/questions/7893396/subversion-client-version-confusion

_________________________________________

To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not the subject) of your e-mail.

[mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
Mathias LIN
Meta Healthcare Systems Ltd.
20/F Central Tower, 28 Queen's Rd Central, Hong Kong
T +852 8199 9605, M +86 159 0208 1701, Skype: mathias.lin
http://www.metahealthcare.com
Ben Wolfe (openmrs) Ben Wolfe (openmrs)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

I would guess it has something to do with the buildnumber plugin not liking 1.7+ layout. 
http://mojo.codehaus.org/buildnumber-maven-plugin

You could take that out temporarily so you can build.  Some quick googling didn't give me an answer for you.

Ben

On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare <[hidden email]> wrote:
I try to build ('mvn install') the webservices.rest module project,
and getting an error as below:

[ERROR] Failed to execute goal
org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
project webservices.rest-omod: Cannot get the revision information
from the scm repository :
[ERROR] Exception while executing SCM command. svn: The path
'/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
appears to be part of a Subversion 1.7 or greater
[ERROR] working copy.  Please upgrade your Subversion client to use this
[ERROR] working copy.


However, my svn command-line client is version 1.7.4. (I only use the
command line, not any other IDE-integrated tools, not Subclipse, etc.)
(I'm on Mac OS X Lion.) Is the svn command-line client that I'm
calling not the same that MVN SCM would be using?
The error only occurs in the OMOD section, not the API or the main.

This is the error/log:

[INFO] Reactor Summary:healthcare
[INFO]
[INFO] Rest Web Services ................................. SUCCESS [0.293s]
[INFO] Rest Web Services API ............................. SUCCESS [4.558s]
[INFO] Rest Web Services OMOD ............................ FAILURE [2.022s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 7.725s
[INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
[INFO] Final Memory: 11M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
project webservices.rest-omod: Cannot get the revision information
from the scm repository :
[ERROR] Exception while executing SCM command. svn: The path
'/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
appears to be part of a Subversion 1.7 or greater
[ERROR] working copy.  Please upgrade your Subversion client to use this
[ERROR] working copy.
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with
the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :webservices.rest-omod


Checking svn client version:

MacBookPro:webservices.rest myuser$ svn help
usage: svn <subcommand> [options] [args]
Subversion command-line client, version 1.7.4.

I've searched for this issue on StackOverflow before and found two
related threads, but not a answer for my case.

http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
http://stackoverflow.com/questions/7893396/subversion-client-version-confusion

_________________________________________

To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not the subject) of your e-mail.

[mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]


[hidden email] from OpenMRS Developers' mailing list
Mathias Lin Mathias Lin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

Thanks Ben, that solves it temporarily. Can build now.


On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:

> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>
> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list

_________________________________________

To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not the subject) of your e-mail.

[mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
Mathias LIN
Meta Healthcare Systems Ltd.
20/F Central Tower, 28 Queen's Rd Central, Hong Kong
T +852 8199 9605, M +86 159 0208 1701, Skype: mathias.lin
http://www.metahealthcare.com
Mathias Lin Mathias Lin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

In reply to this post by Ben Wolfe (openmrs)
Seems that 1.7 support has just been added to the
buildnumber-maven-plugin on 31.3.12,
http://markmail.org/message/metpewfasfmls3uw
so it's not yet in the latest buildnumber-maven-plugin version.


On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:

> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>
> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list

_________________________________________

To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not the subject) of your e-mail.

[mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
Mathias LIN
Meta Healthcare Systems Ltd.
20/F Central Tower, 28 Queen's Rd Central, Hong Kong
T +852 8199 9605, M +86 159 0208 1701, Skype: mathias.lin
http://www.metahealthcare.com
sunbiz sunbiz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

I've been following this upgrade from sometime now and the easiest way now is to use the command line svn client.
Buildnumber plugin will automatically use the command client if you have installed that and will allow the build to run fine

---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE


On 13 April 2012 09:46, Mathias Lin | Meta Healthcare <[hidden email]> wrote:
Seems that 1.7 support has just been added to the
buildnumber-maven-plugin on 31.3.12,
http://markmail.org/message/metpewfasfmls3uw
so it's not yet in the latest buildnumber-maven-plugin version.


On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:
> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>
> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list


[hidden email] from OpenMRS Developers' mailing list
sunbiz sunbiz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

You would have to remove the following from pom.xml:
<providerImplementations>
               <svn>javasvn</svn>
</providerImplementations> 


---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE


On 13 April 2012 14:16, Mathias Lin <[hidden email]> wrote:
Hi Saptarshi, I'm only using the svn command line client already. It doesn't work. (svn client 1.7.4, Mac OS X).
Are you referring to building the webservices.rest module (using buildnumber-maven-plugin 1.0 ?)?


On Fri, Apr 13, 2012 at 4:23 PM, Saptarshi Purkayastha <[hidden email]> wrote:
I've been following this upgrade from sometime now and the easiest way now is to use the command line svn client.
Buildnumber plugin will automatically use the command client if you have installed that and will allow the build to run fine

---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE



On 13 April 2012 09:46, Mathias Lin | Meta Healthcare <[hidden email]> wrote:
Seems that 1.7 support has just been added to the
buildnumber-maven-plugin on 31.3.12,
http://markmail.org/message/metpewfasfmls3uw
so it's not yet in the latest buildnumber-maven-plugin version.


On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:
> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>
> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list


[hidden email] from OpenMRS Developers' mailing list



[hidden email] from OpenMRS Developers' mailing list
sunbiz sunbiz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

With SVNKit 1.7.4 released, which supports SVN 1.7 format, the solution that I've been recommended by the developers of the buildnumber plugin is to use:

<groupId>org.codehaus.mojo</groupId>
<artifactId>buildnumber-maven-plugin</artifactId>
<version>1.0</version>
<dependencies>
    <dependency>
         <groupId>org.tmatesoft.svnkit</groupId>
         <artifactId>svnkit</artifactId>
         <version>1.7.4-v1</version>
    </dependency>
</dependencies>

After this, even if you do not have the svn client installed, it should build find using the javasvn thing...
Should I commit this to the pom.xml for the webservices.rest and trunk

---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE


On 13 April 2012 14:40, Mathias Lin <[hidden email]> wrote:
Oh ok, I see what you mean. I had removed the entire buildnumber-maven-plugin plugin before, but javasvn would already do, and I'd still get my version number generated. Got it. Thanks!


On Fri, Apr 13, 2012 at 4:50 PM, Saptarshi Purkayastha <[hidden email]> wrote:
You would have to remove the following from pom.xml:
<providerImplementations>
               <svn>javasvn</svn>
</providerImplementations> 


---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE


On 13 April 2012 14:16, Mathias Lin <[hidden email]> wrote:
Hi Saptarshi, I'm only using the svn command line client already. It doesn't work. (svn client 1.7.4, Mac OS X).
Are you referring to building the webservices.rest module (using buildnumber-maven-plugin 1.0 ?)?


On Fri, Apr 13, 2012 at 4:23 PM, Saptarshi Purkayastha <[hidden email]> wrote:
I've been following this upgrade from sometime now and the easiest way now is to use the command line svn client.
Buildnumber plugin will automatically use the command client if you have installed that and will allow the build to run fine

---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE



On 13 April 2012 09:46, Mathias Lin | Meta Healthcare <[hidden email]> wrote:
Seems that 1.7 support has just been added to the
buildnumber-maven-plugin on 31.3.12,
http://markmail.org/message/metpewfasfmls3uw
so it's not yet in the latest buildnumber-maven-plugin version.


On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:
> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>
> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list


[hidden email] from OpenMRS Developers' mailing list



[hidden email] from OpenMRS Developers' mailing list



[hidden email] from OpenMRS Developers' mailing list
Friedman, Roger (CDC/CGH/DGHA) (CTR) Friedman, Roger (CDC/CGH/DGHA) (CTR)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

Saptarshi --

I think this is due to your setup.  I am running svn 1.6 and have none of the problems you have identified.  I would say do not commit.

Saludos, Roger

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Saptarshi Purkayastha
Sent: Thursday, May 17, 2012 8:06 AM
To: [hidden email]
Subject: Re: [OPENMRS-DEV] svn client version: The path '/openmrs-modules/webservices.rest' appears to be part of a Subversion 1.7 or greater working copy

 

With SVNKit 1.7.4 released, which supports SVN 1.7 format, the solution that I've been recommended by the developers of the buildnumber plugin is to use:

 

<groupId>org.codehaus.mojo</groupId>

<artifactId>buildnumber-maven-plugin</artifactId>

<version>1.0</version>

<dependencies>

    <dependency>

         <groupId>org.tmatesoft.svnkit</groupId>

         <artifactId>svnkit</artifactId>

         <version>1.7.4-v1</version>

    </dependency>

</dependencies>

 

After this, even if you do not have the svn client installed, it should build find using the javasvn thing...

Should I commit this to the pom.xml for the webservices.rest and trunk


---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE

On 13 April 2012 14:40, Mathias Lin <[hidden email]> wrote:

Oh ok, I see what you mean. I had removed the entire buildnumber-maven-plugin plugin before, but javasvn would already do, and I'd still get my version number generated. Got it. Thanks!

 

On Fri, Apr 13, 2012 at 4:50 PM, Saptarshi Purkayastha <[hidden email]> wrote:

You would have to remove the following from pom.xml:

<providerImplementations>

               <svn>javasvn</svn>

</providerImplementations> 

 

 

---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE

On 13 April 2012 14:16, Mathias Lin <[hidden email]> wrote:

Hi Saptarshi, I'm only using the svn command line client already. It doesn't work. (svn client 1.7.4, Mac OS X).

Are you referring to building the webservices.rest module (using buildnumber-maven-plugin 1.0 ?)?

 

On Fri, Apr 13, 2012 at 4:23 PM, Saptarshi Purkayastha <[hidden email]> wrote:

I've been following this upgrade from sometime now and the easiest way now is to use the command line svn client.

Buildnumber plugin will automatically use the command client if you have installed that and will allow the build to run fine


---
Regards,
Saptarshi PURKAYASTHA

My Tech Blog:  http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE



On 13 April 2012 09:46, Mathias Lin | Meta Healthcare <[hidden email]> wrote:

Seems that 1.7 support has just been added to the
buildnumber-maven-plugin on 31.3.12,
http://markmail.org/message/metpewfasfmls3uw
so it's not yet in the latest buildnumber-maven-plugin version.



On Fri, Apr 13, 2012 at 11:01 AM, Ben Wolfe <[hidden email]> wrote:

> I would guess it has something to do with the buildnumber plugin not liking
> 1.7+ layout.
> http://mojo.codehaus.org/buildnumber-maven-plugin
>
> You could take that out temporarily so you can build.  Some quick googling
> didn't give me an answer for you.
>
> Ben
>
> On Thu, Apr 12, 2012 at 10:38 PM, Mathias Lin | Meta Healthcare
> <[hidden email]> wrote:
>>
>> I try to build ('mvn install') the webservices.rest module project,
>> and getting an error as below:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>>
>>
>> However, my svn command-line client is version 1.7.4. (I only use the
>> command line, not any other IDE-integrated tools, not Subclipse, etc.)
>> (I'm on Mac OS X Lion.) Is the svn command-line client that I'm
>> calling not the same that MVN SCM would be using?
>> The error only occurs in the OMOD section, not the API or the main.
>>
>> This is the error/log:
>>
>> [INFO] Reactor Summary:healthcare
>> [INFO]
>> [INFO] Rest Web Services ................................. SUCCESS
>> [0.293s]
>> [INFO] Rest Web Services API ............................. SUCCESS
>> [4.558s]
>> [INFO] Rest Web Services OMOD ............................ FAILURE
>> [2.022s]
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.725s
>> [INFO] Finished at: Fri Apr 13 02:41:27 CST 2012
>> [INFO] Final Memory: 11M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:buildnumber-maven-plugin:1.0:create (default) on
>> project webservices.rest-omod: Cannot get the revision information
>> from the scm repository :
>> [ERROR] Exception while executing SCM command. svn: The path
>> '/Users/myuser/Projects/healthcare/openmrs-modules/webservices.rest'
>> appears to be part of a Subversion 1.7 or greater
>> [ERROR] working copy.  Please upgrade your Subversion client to use this
>> [ERROR] working copy.
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> [ERROR]
>> [ERROR] After correcting the problems, you can resume the build with the
>> command
>> [ERROR]   mvn <goals> -rf :webservices.rest-omod
>>
>>
>> Checking svn client version:
>>
>> MacBookPro:webservices.rest myuser$ svn help
>> usage: svn <subcommand> [options] [args]
>> Subversion command-line client, version 1.7.4.
>>
>> I've searched for this issue on StackOverflow before and found two
>> related threads, but not a answer for my case.
>>
>> http://stackoverflow.com/questions/7887395/svn-1-7-1-issue
>>
>> http://stackoverflow.com/questions/7893396/subversion-client-version-confusion
>>
>> _________________________________________
>>
>> To unsubscribe from OpenMRS Developers' mailing list, send an e-mail to
>> [hidden email] with "SIGNOFF openmrs-devel-l" in the  body (not
>> the subject) of your e-mail.
>>
>> [mailto:[hidden email]?body=SIGNOFF%20openmrs-devel-l]
>
>

> ________________________________
> Click here to unsubscribe from OpenMRS Developers' mailing list

 


[hidden email] from OpenMRS Developers' mailing list

 

 


[hidden email] from OpenMRS Developers' mailing list

 

 


[hidden email] from OpenMRS Developers' mailing list

Loading...